Je crash FG au démarrage ....

Voir le sujet précédent Voir le sujet suivant Aller en bas

Je crash FG au démarrage ....

Message  JackyB le Dim 10 Aoû 2014 - 19:12

Bonjour à tous,

Après les GIT du matin, je n'arrive plus a démarrer FG, la console est normale, l'invite de fermeture donne ceci

Signature du problème :
Nom d’événement de problème: APPCRASH
Nom de l’application: fgfs.exe
Version de l’application: 0.0.0.0
Horodatage de l’application: 53ce747d
Nom du module par défaut: fgfs.exe
Version du module par défaut: 0.0.0.0
Horodateur du module par défaut: 53ce747d
Code de l’exception: c0000005
Décalage de l’exception: 0000000000a3f6c0
Version du système: 6.1.7601.2.1.0.768.3
Identificateur de paramètres régionaux: 1036
Information supplémentaire n° 1: 41bc
Information supplémentaire n° 2: 41bcff4dbaa60a97d6c3a01189470c44
Information supplémentaire n° 3: 7ceb
Information supplémentaire n° 4: 7cebb844549179591ddfbe19353b4192
 Sad 

Quelqu'un aurait une idée ? Mes recherches n'ont rien donné de constructif.
Au plaisir de vous lire ...bientôt
Jacky

JackyB
Pilote d'avions radiocommandés

Messages : 109
Date d'inscription : 23/03/2012
Age : 68
Localisation : près de St Germain en Laye

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Je crash FG au démarrage ....

Message  Patten le Lun 11 Aoû 2014 - 9:54

Bonjour à tous, bonjour JackyB,

Certes, je ne suis pas sous Windows, mais je n'ai jamais vu ce genre de message (je sais, ma réponse ne va pas t'aider  Embarassed  ).

Ta dernière mise à jour datait de quand? (V.3.3.0 ?).

Pour ce qui me concerne, j'ai mis à jour hier matin, et à part quelques freezes à la fermeture de temps en temps, RAS. (solution: CTRL C dans la console)

Du coup, j'hésite à mettre à jour aujourd'hui  Laughing  , c'est un des inconvénients d'avoir une version en développement, on bénéficie des dernières avancées, mais aussi, on "essuie les plâtres".

Dans ton cas, à part refaire une M à J, je ne vois pas trop de solution, je suppose que tu as essayé en partant d'autres aéroports, et avec un autre aéronef...

Serais-ce lié à ce soucis?:

http://fr.flightgear.org/forums/viewtopic.php?pid=28375#p28375


 Very Happy 



_________________
Ils ont les montres, nous on a le temps...
Pour les textures du terrrain, c'est ICI

Mon hangar en chantier ICI

Oublies ce que tu as donné, souviens toi toujours de ce que tu as reçu...
avatar
Patten
Pilote de chasse

Messages : 3206
Date d'inscription : 16/01/2011
Age : 62

Voir le profil de l'utilisateur http://pattenflightgear.wifeo.com/

Revenir en haut Aller en bas

Re: Je crash FG au démarrage ....

Message  Patten le Lun 11 Aoû 2014 - 11:02

Bon, j'ai fait le choix de ne faire qu'un git pull, mauvaise pioche, Fg ne se lance plus non plus:
À EGOD
Code:
Ack! unknown use material name = Ocean

À LFLR

Code:
Enabling ATI viewport hack
Starting automatic scenery download/synchronization. Using built-in SVN support. Directory: '/home/titi16/Terrasync'.
No path in sim/sound/path
bind(192.168.1.10:5000) failed. Errno 99 (Cannot assign requested address)
Cannot enable multiplayer mode: binding receive socket failed. Cannot assign requested address(errno 99)
Failed to load file: "altimeter/altimeter.xml"
Failed to load file: "gps/gps.xml"
Failed to load file: "vsi/vsi.xml"
environment init
Animated jetways ... initialized
Systems ... Check
Segmentation fault

Idem en lançant Fg en "Global", et .dds.

Help, quelle est la ligne de commande pour revenir dans l'état de avant le git pull svp?.

 Very Happy 

_________________
Ils ont les montres, nous on a le temps...
Pour les textures du terrrain, c'est ICI

Mon hangar en chantier ICI

Oublies ce que tu as donné, souviens toi toujours de ce que tu as reçu...
avatar
Patten
Pilote de chasse

Messages : 3206
Date d'inscription : 16/01/2011
Age : 62

Voir le profil de l'utilisateur http://pattenflightgear.wifeo.com/

Revenir en haut Aller en bas

Re: Je crash FG au démarrage ....

Message  Patten le Lun 11 Aoû 2014 - 11:14

Après un git reset --hard HEAD:
Code:
~/fgfs/install/flightgear/fgdata $ git reset --hard HEAD
HEAD is now at 48153fa New airplane : Albatros B.II

Le résultat est le même impossible de lancer Fg, au mieux on aperçoit l'aéroport pas texturé, puis segmentation fault.  What a Face .

 Very Happy 

_________________
Ils ont les montres, nous on a le temps...
Pour les textures du terrrain, c'est ICI

Mon hangar en chantier ICI

Oublies ce que tu as donné, souviens toi toujours de ce que tu as reçu...
avatar
Patten
Pilote de chasse

Messages : 3206
Date d'inscription : 16/01/2011
Age : 62

Voir le profil de l'utilisateur http://pattenflightgear.wifeo.com/

Revenir en haut Aller en bas

Re: Je crash FG au démarrage ....

Message  Patten le Lun 11 Aoû 2014 - 11:49

Un ./download_and_compile.sh -u -j12 ALL et tout est rentré dans l'ordre.  Suspect 

 Very Happy 

_________________
Ils ont les montres, nous on a le temps...
Pour les textures du terrrain, c'est ICI

Mon hangar en chantier ICI

Oublies ce que tu as donné, souviens toi toujours de ce que tu as reçu...
avatar
Patten
Pilote de chasse

Messages : 3206
Date d'inscription : 16/01/2011
Age : 62

Voir le profil de l'utilisateur http://pattenflightgear.wifeo.com/

Revenir en haut Aller en bas

Re: Je crash FG au démarrage ....

Message  JackyB le Lun 11 Aoû 2014 - 15:29

Bonjour,

ça j'avais eu samedi  Ack! unknown use material name = Ocean mais c’était revenu normal au second git.
Après bien des recherches, des vérifications diverses et variées, je pensais à un problème matériel, donc mise à jour driver et pilote graphique, défragmentation disque etc ... aucun changement.
Le problème venant d'après le message de fgfs.exe j'ai cherché à le remplacer. Une visite sur le site de Jenkins pour m'apercevoir qu'une version d'hier soir était en ligne, j'ai démonté l'ancienne version et monté la dernière.

A priori tout refonctionne correctement maintenant, bon à savoir pour les windosiens ....
A bientôt, en "vol"   Very Happy

JackyB
Pilote d'avions radiocommandés

Messages : 109
Date d'inscription : 23/03/2012
Age : 68
Localisation : près de St Germain en Laye

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Je crash FG au démarrage ....

Message  Patten le Lun 11 Aoû 2014 - 15:58

L'incident est clos  Wink  .

À bientôt en l'air.

Ps: Pas de micro en état en ce moment, je vous ai entendu parler en Corse l'autre jour, mais pas de réponses de ma part... Laughing 

En ce moment, je n'ai non plus pas toujours le nez sur l'écran de Fg, uniquement lorsque je fais de "reload aircraft model", bref, si je ne réponds pas même par écrit (ou trop tard), c'est pas parce que je fais la gueule  Very Happy  Very Happy 

 Very Happy 

_________________
Ils ont les montres, nous on a le temps...
Pour les textures du terrrain, c'est ICI

Mon hangar en chantier ICI

Oublies ce que tu as donné, souviens toi toujours de ce que tu as reçu...
avatar
Patten
Pilote de chasse

Messages : 3206
Date d'inscription : 16/01/2011
Age : 62

Voir le profil de l'utilisateur http://pattenflightgear.wifeo.com/

Revenir en haut Aller en bas

Re: Je crash FG au démarrage ....

Message  JackyB le Lun 11 Aoû 2014 - 17:44

Aucun soucis Christian, je comprends , et bravo encore pour la dernière version de l'alouette 2, très sympa, il te suffit de regarder le traker pour voir qu'elle est utilisée.
Pour FG Com, je suis un peu déçu, très peu de gens l'utilise, y compris les ATC, alors que c'est un bon outil. Peut être faut il faire un cours sur le réglage du "squelch" ...
En vol en général je monitor 123.45.
Bonne continuation dans ton AS ... et au plaisir
Jacky

JackyB
Pilote d'avions radiocommandés

Messages : 109
Date d'inscription : 23/03/2012
Age : 68
Localisation : près de St Germain en Laye

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Je crash FG au démarrage ....

Message  f-ojac le Mar 12 Aoû 2014 - 23:38

Il y a eu des correction sur la syntaxe des fichiers des textures régionales, donc il fallait mettre à jour fgdata + le reste ;-)

f-ojac
pilote de vieux coucous

Messages : 338
Date d'inscription : 23/02/2012
Localisation : En ce bas monde.

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Je crash FG au démarrage ....

Message  Alexis le Mer 13 Aoû 2014 - 1:14

À propos de problèmes, j'ai essayé de compiler fg moi même sous Windows, si si ... Malheureusement sans succès.

Il faut dire que c'est un peu le parcours du combattant, le gros du soucis doit venir de moi même mais je pense que la doc dispo (notamment le wiki) n'est pas au point sur le sujet, elle manque en tout cas de précisions. J'arrive à corriger une partie des problèmes rencontrés par déduction des messages d'erreurs mais ça ne fait pas tout. Je suis pourtant persuadé que tout peut fonctionner convenablement, comme sous linux car toute la machinerie est là.

Enfin bref, je vais rester sur du tout cuit tout compilé, comme avant et je m'attaquerais un de ces jours à ce soucis et pourquoi pas accoucher d'une documentation détaillée sur le sujet.

PS : j'ai tendu pas mal de perches aux linuxiens, je devine déjà vos réponses. Mais non, le passage sous linux n'est pas encore prévu. je finirais sans doute par installer un second disque dur et fonctionner en dual boot.
avatar
Alexis
Admin

Messages : 2053
Date d'inscription : 19/02/2009
Age : 24
Localisation : Loire Atlantique

Voir le profil de l'utilisateur http://fgalexis.jimdo.com/

Revenir en haut Aller en bas

Re: Je crash FG au démarrage ....

Message  Alexis le Mer 13 Aoû 2014 - 1:29

Deuxième message (bin ou j''en poste plusieurs, je rattrape le temps perdu  Very Happy ) pour un petit rappel, le forum de la PAF n'est pas le support le plus adapté pour l’assistance technique en cas de soucis, le forum FG France reste le plus adapté. On peut bien entendu faire exception des problèmes ou des questions concernant des contributions de membres de la PAF.

Merci et bon vol, maintenant que le problème est solutionné !
@++ Alexis
avatar
Alexis
Admin

Messages : 2053
Date d'inscription : 19/02/2009
Age : 24
Localisation : Loire Atlantique

Voir le profil de l'utilisateur http://fgalexis.jimdo.com/

Revenir en haut Aller en bas

Re: Je crash FG au démarrage ....

Message  F-JJTH le Mer 13 Aoû 2014 - 2:07

Pour compiler FG sous Windows: écrit sur le forum france et j'y répondrai Wink

_________________
Premier vol solo : 12/06/2012
Visitez le Hangar de la PAF
Mon Hangar : http://clemaez.fr/flightgear = Script pour terragear-cs + apt850

Le seul moment où vous avez trop de carburant est quand l'ULM est en feu. (Issue du manuel du pilote ULM )
avatar
F-JJTH
Pilote de Ligne

Messages : 2010
Date d'inscription : 19/01/2011
Age : 28
Localisation : Carpentras - LFNH

Voir le profil de l'utilisateur http://www.clemaez.fr/flightgear

Revenir en haut Aller en bas

Re: Je crash FG au démarrage ....

Message  Alexis le Mer 13 Aoû 2014 - 11:01

Merci Clément Very Happy 
avatar
Alexis
Admin

Messages : 2053
Date d'inscription : 19/02/2009
Age : 24
Localisation : Loire Atlantique

Voir le profil de l'utilisateur http://fgalexis.jimdo.com/

Revenir en haut Aller en bas

Re: Je crash FG au démarrage ....

Message  JackyB le Mer 13 Aoû 2014 - 15:51

Bonjour à tous,

f-ojac a écrit:Il y a eu des correction sur la syntaxe des fichiers des textures régionales, donc il fallait mettre à jour fgdata + le reste ;-)

Depuis que Clément a expliqué dans un autre post (GIT 2.99 versus 3.0.0) les mises à jour à faire, je ne manque jamais de TOUT mettre à jour, mais le ack est apparu quand même ... de même que les rockets du Mil 24 ne passaient pas ... un reset --hard et tout va mieux. En parlant texture, il y a de nombreux endroits ou les niveaux et ou les textures ne fonctionnent pas (  LFPB est toujours sous terre, Le Pas de La Case en Andorre est un désert gris, le viaduc de Millau est dans le vide ....aux extrémités ...etc)

Pour Alexis, il y a une méthode très simple pour monter un FG  sous windows:
il suffit de cloner dans un répertoire les dossiers suivants:
fgdata
fgmetar
fgrun
flightgear
fgsimgear
d'exécuter le fgfs_win32 ou64_vs2010_nightly_3.3.0

et tout baigne, ça prend 5 minutes hors clone qui est relatif à ta connexion internet et de l'heure à laquelle tu le fais.
Pour l'autre forum, je n'arrive plus a y accéder depuis deux ans peut être plus, il y a un problème sur mon compte, ou je suis banni peut être,  Very Happy , il reconnait  mon adresse mail, me dit que j'ai déjà un compte mais il ne veut pas me connecter mais bon, ça me manque pas non plus, je n'apporterais pas grand chose.
A bientôt, en vol, avec FG Com, et de beaux appareils bien simulés ....
Jacky

JackyB
Pilote d'avions radiocommandés

Messages : 109
Date d'inscription : 23/03/2012
Age : 68
Localisation : près de St Germain en Laye

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Je crash FG au démarrage ....

Message  f-ojac le Mer 13 Aoû 2014 - 22:02

JackyB a écrit:En parlant texture, il y a de nombreux endroits ou les niveaux et ou les textures ne fonctionnent pas (  LFPB est toujours sous terre, Le Pas de La Case en Andorre est un désert gris, le viaduc de Millau est dans le vide ....aux extrémités ...etc)
Je pense que ce sont des problèmes séparés. Je vais jeter un œil. Pour Millau c'est certainement qu'il n'a pas été repositionné depuis la dernière mise à jour du terrain : je viens de corriger, tu me diras si c'est mieux. Pour LFPB, et la région parisienne en général, il faut attendre la prochaine version du terrain (pb de densité OSM). Ce n'est pas lié aux textures.

f-ojac
pilote de vieux coucous

Messages : 338
Date d'inscription : 23/02/2012
Localisation : En ce bas monde.

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Je crash FG au démarrage ....

Message  JackyB le Ven 15 Aoû 2014 - 0:32

Bonsoir,

Pour Millau je peux confirmer c'est toujours pareil, je viens juste de vérifier ... un jour peut être ....
Bonne soirée
Jacky

JackyB
Pilote d'avions radiocommandés

Messages : 109
Date d'inscription : 23/03/2012
Age : 68
Localisation : près de St Germain en Laye

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Je crash FG au démarrage ....

Message  f-ojac le Ven 15 Aoû 2014 - 0:51

Salut Jacky,
Je te confirme que je l'ai modifié hier : https://code.google.com/p/terrascenery/source/diff?spec=svn52629&r=51264&format=side&path=/trunk/data/Scenery/Objects/e000n40/e003n44/3006848.stg&old_path=/trunk/data/Scenery/Objects/e000n40/e003n44/3006848.stg&old=46544 c'est pas parfait mais un peu mieux. Tu utilises bien le terrain de terrasync ? Si oui tu devrais voir une petite amélioration.

f-ojac
pilote de vieux coucous

Messages : 338
Date d'inscription : 23/02/2012
Localisation : En ce bas monde.

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Je crash FG au démarrage ....

Message  JackyB le Ven 15 Aoû 2014 - 18:09

Absolument, je confirme c'est bon maintenant, le viaduc a repris sa bonne place.
Je crois qu'il faut attendre en fait entre 24 et 36 h entre le moment ou est fait la modification et son accès réel sur le système.

A bientôt
Jacky

JackyB
Pilote d'avions radiocommandés

Messages : 109
Date d'inscription : 23/03/2012
Age : 68
Localisation : près de St Germain en Laye

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Je crash FG au démarrage ....

Message  f-ojac le Sam 16 Aoû 2014 - 13:13

Oui il y a normalement deux exports Terrasync par jour, donc suivant quand la validation est faite, il faut attendre effectivement 24h. Content si c'est mieux.

f-ojac
pilote de vieux coucous

Messages : 338
Date d'inscription : 23/02/2012
Localisation : En ce bas monde.

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Je crash FG au démarrage ....

Message  Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum