Question sur le xml

Voir le sujet précédent Voir le sujet suivant Aller en bas

Question sur le xml

Message  G-LUBS le Lun 27 Fév 2017 - 15:44

Bonjour à tous et en particulier aux spécialistes du codage xml dont je recherche l'expertise,
En synthèse, mon modèle .blend exporté en .ac ne s'affiche pas sous FG !
En procédant par analogie et empirisme, j'en suis réiuit à penser que mon fichier avion.xml n'est pas au top et interdit (par quel effet ?) l'affichage du fichier avion.ac...
Pour être plus explicite, je squatte le fichier F86 Sabre du site officiel : j'ai réalisé mon propre F86A sous Blender 2.78 et j'ai testé sa compatibilité dans l'environnement FG 2016.4.4 Windows X par export avec l'addon AC3D, c'est tout bon ! (après quelques mises au point tout de même !!!).
Du coup, j'ai entrepris la modification du .xml principalement pour les animations en y réécrivant les constituants de mon modèle et je me suis alors rendu compte qu'aucun des .ac originaux (comme le cockpit...) en plus de mon modèle ne s'affichaient. J'ai procédé par élimination entre mon dossier modifié et le dossier original mais maintenant je coince en ayant isolé comme cause le .xml que je modifie...
Avez-vous à ce sujet quelques idées sur l'écriture du .xml qui induirait l'absence de l'affichage des .ac ?
Merci de vos avis.
A+

G-LUBS
Mécano

Messages : 46
Date d'inscription : 22/09/2016

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Question sur le xml

Message  Patten le Lun 27 Fév 2017 - 16:37

G-LUBS a écrit:...........
Avez-vous à ce sujet quelques idées sur l'écriture du .xml qui induirait l'absence de l'affichage des .ac ?
Merci de vos avis.
A+

Déjà regarder ce qu'il se passe dans la console.
Sinon, un simple avion.xml codé comme ci-dessous suffit à faire apparaître ton modèle 3D dans FG, dans la mesure ou l'export s'est bien passé avec Blender, et que les chemins sont bien renseignés dans le dossier de ton avion.
La vigilance concernant la casse est de mise bien entendu:

Code:
<?xml version="1.0" encoding="ISO-8859-1"?>

<PropertyList>

  <path>avion.ac</path>

</PropertyList>

Very Happy

_________________
C'est quand il manque quelqu'un qu'on est tous présents.
Pour les textures du terrrain, c'est ICI

Mon hangar en chantier ICI

Oublies ce que tu as donné, souviens toi toujours de ce que tu as reçu...
avatar
Patten
Pilote de chasse

Messages : 3217
Date d'inscription : 16/01/2011
Age : 62

Voir le profil de l'utilisateur http://pattenflightgear.wifeo.com/

Revenir en haut Aller en bas

Re: Question sur le xml

Message  clm76 le Lun 27 Fév 2017 - 16:57

Bonjour G-LUBS,

je me suis alors rendu compte qu'aucun des .ac originaux (comme le cockpit...) en plus de mon modèle ne s'affichaient
Si tu peux nous mettre ton fichier avion en .zip chez un hébergeur et le lien qui va avec, je peux regarder où cela coince.

clm76
Le baron rouge

Messages : 428
Date d'inscription : 27/10/2014
Age : 69
Localisation : Normandie

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Question sur le xml

Message  G-LUBS le Lun 27 Fév 2017 - 18:18

En fait, il manquait la balise de fin --> d'un commentaire titre d'un ensemble de fonctions isolées par commentaires successifs que j'avais écrites pour essai de ces options genre mouvement des becs par translation et rotation ...Comme quoi un rien suffit à enrayer le process !
Le fichier du F86 Sabre est bizarrement écrit en particulier chaque axe avec 2 points de référence est systématiquement précédé d'un <center></center> ! A priori, il faut que je le contrôle, cela ne produit pas sur l'original ce que je vois sur mon modèle...

G-LUBS
Mécano

Messages : 46
Date d'inscription : 22/09/2016

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Question sur le xml

Message  Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum